PHP Warning: Version warning: Imagick was compiled against Image Magick version 1690 but version 1691 is loaded

After I update the PHP to the newest version 7.3.15 and this errr appear in my CentOS 7

# php --version
PHP Warning:  Version warning: Imagick was compiled against Image Magick version 1690 but version 1691 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0
PHP 7.3.15 (cli) (built: Apr  1 2020 16:03:41) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.15, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.3.15, Copyright (c) 1999-2018, by Zend Technologies

Solved by this solution

Here i noted down the step I solve this problem that found from centminmod forums

yum versionlock delete ImageMagick6 ImageMagick6-devel ImageMagick6-c++ ImageMagick6-c++-devel ImageMagick6-libs
yum -y install ImageMagick6 ImageMagick6-devel ImageMagick6-c++ ImageMagick6-c++-devel ImageMagick6-libs --enablerepo=remi
yum versionlock ImageMagick6 ImageMagick6-devel ImageMagick6-c++ ImageMagick6-c++-devel ImageMagick6-libs

Tags:

Leave a Comment

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.